stopped working with php82-8.2.18

by snak-pak, Saturday, May 18, 2024, 22:05 (32 days ago)

I've been using Selfoss for many years now and love it. Unfortunately it suddenly stopped working. The only change on my side has been an upgrade from an early version of php 8.2.x to php 8.2.18. I'm getting database connection errors with both sqlite and mysql that look like this in the log:

[2024-05-18T19:33:42.850580+00:00] selfoss.ERROR: SQLSTATE[HY000]: General error: 1360 Trigger does not exist {"exception":"[object] (PDOException(code: HY000): SQLSTATE[HY000]: General error: 1360 Trigger does not exist at /usr/local/www/nginx/mywebsite.com/src/helpers/DatabaseConnection.php:140)

I was using sqlite so I switched to mysql to test things and got the same error, yet when I check mysql from the shell the database connection did in fact work and tables got created in a fresh new database, despite seeing the above error.

My main setup is Nginx with PHP-FPM but I've also tested it with Apache24 and mod_php and got the same error, both are running php 8.2.18 now. I also tested both sqlite and mysql on the two different systems with the same result. I read through the PHP changelog and didn't find much of interest with any sqlite updates, just a few changes to PDO since 8.2.0 came out.

My Nginx system runs about two dozen websites, most use mysql with php-fpm and they all work fine. I can connect through sockets or over IP.

I've tried the latest Selfoss builds on Github as well as older Github builds from late 2023. Thought I'd ask here before abandoning the software and trying something else.

Maybe I'm just losing my mind. Happy to switch to another version of PHP to get it working again.


Complete thread:

 RSS Feed of thread

powered by my little forum