Can't get selfoss working on Arch/nginx

by PDog, Saturday, April 25, 2015, 10:46 (3286 days ago)


I have followed all directions outlined in the selfoss documentation and in the GitHub wiki entry for nginx configuration. I have installed all necessary dependencies, I have set the proper permissions, and I already have a virtually untouched nginx server running (complete with default "Welcome to nginx!" home page). At this point, I have my selfoss.conf file properly symlinked in sites-enabled with the only necessary line changed in the example file:

server_name; -> server_name

After restarting the nginx service, I expected to see the selfoss landing page, but it just keeps showing the default "Welcome to nginx!" page. I have tried playing around with nginx.conf by replacing the default server block in the file with the server block from the configuration file in the wiki example, but this just causes the page to time out. I have even set the server_name as localhost and pointed to the proper selfoss locations, but this hasn't worked for me either.

I have tried everything I could possibly imagine to get this to work, but after hours of trying, I can't find a solution. I see that several people have successful nginx configurations running, so if anyone could carefully walk me though this, it would be much appreciated.

Can't get selfoss working on Arch/nginx

by PDog, Monday, April 27, 2015, 00:46 (3284 days ago) @ PDog

After a seriously OBSCENE amount of time, I finally managed to get this to work. The process of getting selfoss to work on Arch is ridiculously tedious and complicated, so I'm going to leave a little guide for future readers.

Bear in mind that I spent several hours over a few days trying to get this to work, so I might have forgotten to document some steps and they might be out of order.

Setup with nginx and sqlite
1.) In addition to installing the necessary dependencies listed in the AUR selfoss package, ensure that you also install php-fpm.

2.) Do NOT upload selfoss to /var/www/ - instead, you must upload to /usr/share/webapps/. You have the choice of a few other directories; /usr/share/webapps/ just happens to be one of the locations that works. Unzip selfoss in /usr/share/webapps/selfoss and then delete the zip file if you wish.

3.) Make absolutely sure that you set the proper permissions on the appropriate directories as outlined in the official selfoss documentation.

4.) In your php.ini file (should be /etc/php/php.ini), there should be a line like `listen = /var/run/php5-fpm.sock`. Comment this line and then uncomment the line that reads `listen =`.

5.) While you are in the php.ini file, uncomment the line that reads ``.

6.) Restart the php-fpm service.

7.) Create your selfoss.conf file using the example provided in the wiki guide. Exclude the `upstream` block when you copy/paste. In addition to changing `server_name` to the appropriate value for your domain, make the following changes as well:

  • root /var/www/selfoss/; -> root /usr/share/webapps/selfoss
  • fastcgi_pass backend; -> fastcgi_pass;

Again, don't forgot to exclude the upstream block!! Just copy/paste the server block and make the above changes.

8.) Finish the nginx part of the setup process and restart the nginx service. Everything should be working now. If you are still having issues, check /var/log/nginx/rss.error.log for any funny business. Mess around with the selfoss config.ini file and enjoy the great software.

Can't get selfoss working on Arch/nginx

by PDog, Monday, April 27, 2015, 16:43 (3284 days ago) @ PDog

I encountered some issues while using selfoss and it turns out `` needs to be uncommented as well in php.ini. Don't forget to do this in steps 4/5.

RSS Feed of thread
powered by my little forum