Internal Server Error Fatal error: Directive 'magic_quotes_

by hugh, Tuesday, March 19, 2013, 05:10 (4048 days ago)

Internal Server Error

Fatal error: Directive 'magic_quotes_gpc' is deprecated in PHP 5.3 and greater

That's the message I'm getting over and over. I've read though all the help I can find on this. Magic quotes are turned on in php.ini and data & public folders are writable. I'm kind of lost on what to try next.

Thanks!

Internal Server Error Fatal error: Directive 'magic_quotes_

by oers, Tuesday, March 19, 2013, 08:07 (4048 days ago) @ hugh

magic_quotes have to be turned off. Then this message will go away.

Internal Server Error Fatal error: Directive 'magic_quotes_

by hugh, Tuesday, March 19, 2013, 12:04 (4048 days ago) @ oers

I set magic_quotes_gpc = Off in php.ini it still keeps happening. Anymore ideas?

Also I tried setting php_flag magic_quotes_gpc Off in the .htaccess. When I do that nothing loads. :(

Internal Server Error Fatal error: Directive 'magic_quotes_

by nicouchot, Tuesday, March 19, 2013, 16:08 (4048 days ago) @ hugh

I have the same problem with register_globals :

Fatal error: Directive 'register_globals' is deprecated in PHP 5.3 and greater

It seems to be caused by /selfoss/libs/f3/base.php file lines 1385 and 1386, I don't understand all of the code, but comment say "// Intercept errors/exceptions; PHP5.3-compatible", but it's not compatible !

Any idea tobi ? (great job by the way !)

Internal Server Error Fatal error: Directive 'magic_quotes_

by oers, Tuesday, March 19, 2013, 21:52 (4048 days ago) @ nicouchot

in this thread: http://selfoss.aditu.de/forum/index.php?id=108

I had the same problems and postet my solution.

Internal Server Error Fatal error: Directive 'magic_quotes_

by nicouchot, Wednesday, March 20, 2013, 09:34 (4047 days ago) @ oers

Ok thanks, for me I just had to disable "register_globals" in php.ini !

Internal Server Error Fatal error: Directive 'magic_quotes_

by hugh, Wednesday, March 20, 2013, 11:39 (4047 days ago) @ nicouchot

I've tried setting that to off and just commenting it out. That didn't work for me at all. I'm still getting the same error.

RSS Feed of thread
powered by my little forum