Access via HTTPS shows no stylesheet or images

by nLinked, Tuesday, March 19, 2013, 11:45 (3914 days ago)

Got selfoss installed on Ubuntu Server 12.04.
Works great via http://server/selfoss.
Also works great via http://mydomain.com/selfoss (from outside, over the Internet).

But I want to access it via HTTPS so I can connect from over the Internet from another location securely. When I do this (https://mydomain.com/selfoss), the page loads but only in plaintext. CSS stylesheets and images are missing.

Is there a way to make it work via HTTPS?

Access via HTTPS shows no stylesheet or images

by davideg, Tuesday, March 19, 2013, 13:36 (3914 days ago) @ nLinked

It is working for me. Maybe you forget to include "SSLEngine on" on the apache configuration?

Access via HTTPS shows no stylesheet or images

by nLinked, Tuesday, March 19, 2013, 23:35 (3914 days ago) @ davideg

No joy :-(

I checked /etc/apache2/sites-available/default-ssl and it already has "sslengine on" enabled.

Where could I be going wrong? I looked at this and I'm not sure where the virtual hosts file is. There is an example of virtualhost settings at the bottom of that page, but which file do I put that in?

Access via HTTPS shows no stylesheet or images

by nLinked, Wednesday, March 20, 2013, 00:02 (3914 days ago) @ nLinked

Fixed! It was the AllowOverride None, changed to AllowOverride All. Solved!

Access via HTTPS shows no stylesheet or images

by jcdus, Wednesday, March 20, 2013, 15:47 (3913 days ago) @ nLinked

Hi all,

I had the same issue, but the AllowOverride All wasn't enough to solve the problem: the web page produced by index.php was presented (which is ok), but with no images nor style.

The problem was an error 404 on:
https://server/selfoss/all.js
https://server/selfoss/all.css
and all the files in /var/www/selfoss/public

If this information can help someone, let me explain how I solved my issue:

1/ I made up a selfoss Directory for Selfoss in my Apache conf:

Alias /selfoss "/var/www/selfoss"
<Directory "/var/www/selfoss">
Options FollowSymLinks
Order Allow,Deny
Allow From All
AllowOverride All
</Directory>

2/ I copied the content of /var/www/selfoss/.htaccess in this Directory tag.

3/ I commented out the line:
RewriteBase /selfoss

4/ I deleted the /var/www/selfoss/.htaccess file

5/ Restart Apache, clean caches, access Selfoss and enjoy.

I guess that the "AllowOverride All" line is no more necessary, and maybe that a more obvious and cleaner solution exists, but that's my 2 cents for today.

Jean-Claude.

RSS Feed of thread
powered by my little forum