404 on opml and password login does not work

by steve, Friday, March 15, 2013, 14:34 (4086 days ago)

I finally got selfoss up and running after battling with selinux for a while.

I am using Fedora 18, with nginx and php-fpm.

I am using the configuration mentioned on the troubleshooting thread for nginx.

/update seems to work fine, but /opml gives me a 404 page from php-fpm

The password login does not accept my credentials found in config.ini

404 on opml and password login does not work

by andersgd, Friday, March 15, 2013, 15:07 (4086 days ago) @ steve

Are you running Selfoss 2.2 or higher? Opml came in 2.2

/Anders

404 on opml and password login does not work

by steve, Friday, March 15, 2013, 15:11 (4086 days ago) @ andersgd

Yes, I downloaded the selfoss-2.2.zip today.

404 on opml and password login does not work

by andersgd, Friday, March 15, 2013, 15:28 (4086 days ago) @ steve

Strange. Is the controllers/Opml.php file there?

404 on opml and password login does not work

by steve, Friday, March 15, 2013, 15:31 (4086 days ago) @ andersgd

Yes, and other items like /rss work fine.

404 on opml and password login does not work

by andersgd, Friday, March 15, 2013, 15:41 (4086 days ago) @ steve

Does your selfoss/index.php includes ompl-routing at the end of the file. Eg.
$f3->route('GET /opml', 'controllers\Opml->show');
$f3->route('POST /opml', 'controllers\Opml->add');
at line 84 and 85.

404 on opml and password login does not work

by steve, Friday, March 15, 2013, 15:44 (4086 days ago) @ andersgd

Actually looking at this, it seems since I cannot login which is the other issue, is why this isn't working. So if I can get the login working this should work as well if I'm reading correctly.

The username and password I have in the config.ini file does not work.

404 on opml and password login does not work

by andersgd, Friday, March 15, 2013, 15:55 (4086 days ago) @ steve

I'm currently running without login. Tried enabling it without success.

404 on opml and password login does not work

by andersgd, Friday, March 15, 2013, 16:07 (4086 days ago) @ steve

Is it the password hash you have in config.ini? Not the clear text password. You can generate a password at <your url>/password

404 on opml and password login does not work

by Fred, Friday, March 15, 2013, 16:07 (4086 days ago) @ steve

I assume you've generated a password using http://www.yoursite.com/selfoss/password/ as per the docs, then put the generated password hash into config.ini, and not actually put the plain text password into config.ini?

404 on opml and password login does not work

by steve, Friday, March 15, 2013, 16:11 (4086 days ago) @ Fred

Doh, I actually interchanged password/user in the configuration. At least it was simple.

404 on opml and password login does not work

by kleedrac, Friday, March 15, 2013, 17:27 (4086 days ago) @ Fred

I just got this installed and cannot acces http://myselfoss/password or http://myselfoss/selfoss/password Both give me a 404. I'm using Debian linux (sid) and lighttpd (and I've added the lighttpd section from the troubleshooting thread). Any help would be appreciated :)

404 on opml and password login does not work

by steve, Friday, March 15, 2013, 17:29 (4086 days ago) @ kleedrac

I would check the permissions on your files to make sure they match the info on the documentation page, as well as making sure the owner is the lighttpd user, i think for debian, chown -R www-data:www-data <dir>

404 on opml and password login does not work

by kleedrac, Friday, March 15, 2013, 17:33 (4086 days ago) @ steve

Just double checked and permissions shouldn't be the issue. Still 404'ing on /password

404 on opml and password login does not work

by steve, Friday, March 15, 2013, 17:35 (4086 days ago) @ kleedrac

Does just going to http://myselfoss.url/ work?

404 on opml and password login does not work

by kleedrac, Friday, March 15, 2013, 17:37 (4086 days ago) @ steve

It does work (though I'm not getting any style data for some other reason) When I've got user/pass enabled I can't get it (as I'm unsure how to generate the proper password hash without access to /password) and if I remove it it's just very plain but it works. Another question is should I have selfoss installed (unzipped) in the root of the subdomain or should it be in a folder?

404 on opml and password login does not work

by steve, Friday, March 15, 2013, 17:40 (4086 days ago) @ kleedrac

It looks like the rewrites with lighttpd expect it to be in the folder selfoss

404 on opml and password login does not work

by kleedrac, Friday, March 15, 2013, 17:45 (4086 days ago) @ steve

OK so I've tried creating a selfoss folder but that didn't work, then I tried *copying* everything so it exists both outside and inside said folder but still no help. It may also be worth noting that /update and /opml also 404 :P

404 on opml and password login does not work

by steve, Friday, March 15, 2013, 17:46 (4086 days ago) @ kleedrac

You will have to look at your php/lighttpd logs to find more info

404 on opml and password login does not work

by kleedrac, Friday, March 15, 2013, 18:10 (4086 days ago) @ steve

OK it's up and running! Thanks to everyone who helped! For posterity anyone running lighttpd and wishing to have selfoss on its own subdomain should remove all mentions of the /selfoss/ folder in the url_rewrite_once() stuff and just unzip the whole selfoss into the /html folder. Make sure you check your permissions and restart lighttpd after you alter lighttpd.conf and HAVE FUN!

404 on opml and password login does not work

by Fred, Friday, March 15, 2013, 17:32 (4086 days ago) @ kleedrac

Most likely that you don't have mod_rewrite installed or you've got 'AllowOverride None' in your apache config (this is the default for Debian/Ubuntu). You need to ensure that your apache config is set to 'AllowOverride all' so that the mod_rewrite rules in .htaccess can take effect.

404 on opml and password login does not work

by kleedrac, Friday, March 15, 2013, 17:34 (4086 days ago) @ Fred

As I mentioned I'm using lighttpd and I do have mod_rewrite (I use it extensively for a url shortener) so this isn't the issue

RSS Feed of thread
powered by my little forum