Internal Server Errors

by mcnesium, Wednesday, March 27, 2013, 17:56 (4074 days ago)
edited by mcnesium, Wednesday, March 27, 2013, 18:18

first of all thx for the software - (i blogged about it)

i do experience a number of issues here, that i can not really reproduce everytime, but they do appear “sometimes”.


first of all, when i read through the unread entries, some of them cannot be marked read. a popup appears that says it cant be marked: “Internal Server Error”.
/edit: developer console output:
Failed to load resource: the server responded with a status of 500 (Internal Server Error) http://fluse.fritz.box/mc/rss/mark/520

i tried to add another site, but when i selected the “RSS Feed” option in the select box, the red message “Internal Server Error” appeared instead of the field for the url.

i wanted to reload the page, then i got the blank page with the apache error message “Internal Server Error” and also “Fatal error: Module 'geoip' already loaded” - what is the geoip module doing here? so i had a look in the apache log file, and it said the same right there: “[Wed Mar 27 17:47:35 2013] [error] [client 10.10.10.20] Fatal error: Module 'geoip' already loaded, referer: http://fluse.fritz.box/mc/rss/”

after another full reload the application showed up again. but when i hit the cloud button below to get back to the saved sites, i again get a js-alert with “Load sources error: Internal Server Error” and in the developer console it said:

GET http://fluse.fritz.box/mc/rss/sources 500 (Internal Server Error) all.js:3
send all.js:3
v.extend.ajax all.js:3
selfoss.events.hashChange all.js:1154

i did set chmod a=rwX data/* and public/

run in Chromium 25.0.1364.172 on OSX
hosted by Apache 2.2.22 on Ubuntu 12.10

any ideas what could be wrong here?

Internal Server Errors

by alicea, Wednesday, March 27, 2013, 23:46 (4074 days ago) @ mcnesium

That internal error happened to me a few times and for me, I was logged out so logged back in and issue went away.

Internal Server Errors

by mcnesium, Thursday, March 28, 2013, 09:20 (4074 days ago) @ alicea

i did not even set a login though

Internal Server Errors

by rustin, Thursday, March 28, 2013, 15:01 (4073 days ago) @ mcnesium

Check your php.ini for multiple "extension=geoip.so". It's either in php.ini or external file. After that you'll be able to see the real error.
Had the same problem with multiple "extension=mysql-pdo.so" lines. Turned out I didn't have php-gd library installed.

Internal Server Errors

by mcnesium, Friday, March 29, 2013, 20:13 (4072 days ago) @ rustin

root@fluse:~# grep -ir 'geoip.so' /etc/
Binary file /etc/ld.so.cache matches
/etc/php5/mods-available/geoip.ini:extension=geoip.so
/etc/php5/apache2/php.ini:extension=geoip.so

Internal Server Errors

by rustin, Friday, March 29, 2013, 21:18 (4072 days ago) @ mcnesium

Have you tried to remove the line from php.ini and restart apache?

Internal Server Errors

by mcnesium, Wednesday, April 03, 2013, 17:12 (4067 days ago) @ rustin

yes. result: no error messages at all in error.log

Internal Server Errors

by rustin, Friday, April 05, 2013, 02:18 (4066 days ago) @ mcnesium

So the problem is gone? Or what error do you get now?

Internal Server Errors

by mcnesium, Friday, April 05, 2013, 09:22 (4066 days ago) @ rustin

the internal server error alert in the browser came anyway. but as i stated, in v2.4 i havent seen it in a while…

Internal Server Errors

by mcnesium, Wednesday, April 03, 2013, 17:16 (4067 days ago) @ mcnesium

this happens way less in v2.4. i saw it only twice since i upgraded.

Internal Server Errors

by bluenenschloss ⌂, Solingen, Friday, April 05, 2013, 14:03 (4065 days ago) @ mcnesium
edited by bluenenschloss, Friday, April 05, 2013, 14:11

After several days of newsreading w/o any problems,
I suddenly got an "Internal server error 500 ..." when updating manually.
(http://www.example.com/selfoss/update)

It's version 2.4 with sqlite database and about 12 feeds and ~1.300 news overall.
What went wrong?

Had the same problem with an earlier version (2.3) some days ago.
Only way to get things back to work, was a complete reinstall.
(I would love an export-feature to easily reimport feeds after repeated clean install...)

;-)

edit:
although I get this error, feeds are still updated!
no hints in default.log either...

Internal Server Errors

by mcnesium, Friday, April 05, 2013, 14:16 (4065 days ago) @ bluenenschloss

ok now it happened to me again. i wanted to add a new feed. when i tried to select „RSS Feed“, the „internal server error“ message below the form showed up again. after a reload the „internal server error“ alert comes even when i click „add source“.
plus the „internal server error“ alert is back in the feed list, so every other feed item i read cannot be marked as read. so actually this is the same error as in 2.3, it just took some time to get back here.

i have about 50 feeds in the list and a couple of 100 unread items every day, and i use sqlite as well

Internal Server Errors

by jernst, Friday, February 14, 2014, 02:24 (3751 days ago) @ mcnesium

My version of the problem went away after I removed a second:

extension=curl.so

statement from my php.ini. Depending on your distro, such a second line may also be in some other file, like one contained in /etc/php/conf.d/ (as in my case).

Cheers,


Johannes.

RSS Feed of thread
powered by my little forum