PHP Timeout in "libs/JSMin.php

by CaveCanem, Wednesday, April 10, 2013, 23:14 (4067 days ago)

Hi,

i wanted to try Selfoss on my RaspberryPi but i cant get it work. I only get a white screen with a "Internal Server Error" that says that the maximum Execution Time is exceeded.

The Apache log file says that this happens while executing /libs/JSMin.php, but the lines are different every time (from 0 to 160).

I´ve done everything that is said in the installation instruction.
I´ve got owncloud installed, too, so actually it should work.

I also removed owncloud but that didn´t helped.

The first error i got was "Couldn´t fin "/www/favicon.ico" (selfoss is under "/var/www/selfoss/") that was a bit strange, but i just copied the favicon.ico file, but that didn´t helped as well.

has anyone any idea? thanks

PHP Timeout in "libs/JSMin.php

by Francis, Thursday, April 11, 2013, 01:22 (4067 days ago) @ CaveCanem

Change your php script timeout in php.ini
http://php.net/manual/en/function.set-time-limit.php

PHP Timeout in "libs/JSMin.php

by burliest, Friday, April 19, 2013, 05:15 (4059 days ago) @ CaveCanem

I had the exact same issue when I updated from 2.3 to 2.6 on my Raspberry Pi. The suggestion on this page worked for me: http://forum.thebuggenie.com/viewtopic.php?f=1&t=738. Basically just bypass the minification. I'm sure there's a more elegant solution, but it got the job done.

PHP Timeout in "libs/JSMin.php

by CaveCanem, Friday, April 19, 2013, 10:02 (4059 days ago) @ burliest

Hi,

yup it worked like a charm. I guess it only takes that long when you open selfoss the for first time, because now its quite fast.

PHP Timeout in "libs/JSMin.php

by e.christiaanse, Wednesday, May 15, 2013, 20:21 (4032 days ago) @ burliest

Changing JSmin.php works great, what also worked is changing max_execution_time = 30 in php.ini into max_execution_time = 90

Just a longer wait (without timeout ;) also does the job on selfoss 2.7

In case you're wondering where the php.ini is located on your RasPi, have a look here:
/etc/php5/apache2/php.ini

RSS Feed of thread
powered by my little forum