Installation problems

by sts, Sunday, April 21, 2013, 01:38 (3875 days ago)

I try quite for a while now to install selfoss but without success.
Unfortunately I only get this: [image]

I followed the install instructions as far as I understand them.

I created a new folder "selfoss" in my document root (/var/www) and copied all files in this folder (including .htaccess). I changed the permissions for /data and /public to 777 and I also changed the owner of the selfoss folder to www-data (it's an Ubuntu 12.04 server with Apache and PHP 5.3, mod_rewrite and mod_headers are enabled). I didn't change anything in the default.ini.

I tried to install 2.5 before but just with the same result. However, in the meantime I managed to install tinytinyrss so apache/php should be fine, I suppose.

I just started with 2.6 from scratch again but no luck.
Any help would be much appreciated.

Installation problems

by hemathor, Monday, April 22, 2013, 11:04 (3873 days ago) @ sts
edited by hemathor, Monday, April 22, 2013, 11:14

Any help would be much appreciated.

i know the feeling... :)

the problem is that the rewrite rules in the .htaccess files are not working. (you could have found that yourself, if you checked the apache logs and read something about rewrite rules... ;) )

the first solution would be to uncomment the RewriteBase rule and set it to the proper directory. but since you already have selfoss installed in the subdirectory <document root>/selfoss that probably doesn't change anything.

the second solution is to allow the rewrite rules for selfoss. probably somewhere along the path of your system's configuration include files (i don't know anything about apache on ubuntu), there is a directive

AllowOverride None

and that is exactly why the rewrite rules in the selfoss' .htaccess file are now working. to change this for your selfoss installation w/o affecting the whole apache configuration (because not allowing to override anything is generally a not so bad idea) you should add a configuration file selfoss.conf in your apache configuration directory (again: i have no idea about ubuntu) with the following content:

<Directory "<document root>/selfoss" >
AllowOverride All
</Directory>

where <document root> is probably /var/www on your system...

finally you have to add

Options FollowSymLinks

to the .htaccess file to allow rewrite rules.

don't forget to restart apache after that...

Installation problems

by sts, Monday, April 22, 2013, 22:37 (3873 days ago) @ hemathor

Thanks a million.
That did the trick.

Works like expected now!

RSS Feed of thread
powered by my little forum