uncaught exception on update

by zedug, Tuesday, April 23, 2013, 14:30 (3880 days ago)


first off thanks for this great piece of software, it's pretty much exactly what I was hoping for so congrats to the team :-)

I installed the package correctly and the OPML import from google went well (I have about 140 feeds, about 1200 items showed up) but I'm hitting a snag on updates.

specifics: selfoss 2.6 / PHP 5.3.16 / mysql / using a professional hosting service here in France

When I go manually to <my.server>/selfoss/update it ends up with a 504 Gateway Timeout

When I activate a cron job to <my.server>/selfoss/update.php it returns the message below:

Undefined index: SCRIPT_NAME
PHP Fatal error: Uncaught exception 'ErrorException' with message
'Undefined index: ONERROR' in <my.server>/selfoss/libs/f3/base.php:1399
Stack trace:
#0 <my.server>/selfoss/libs/f3/base.php(862): {closure}(8,
'Undefined index...', '<server info>', 862, Array)
#1 <my.server>/selfoss/libs/f3/base.php(1393): Base-error(500,
'Undefined index...', Array)
#2 [internal function]: {closure}(Object(ErrorException))
#3 {main}
thrown in <my.server>/selfoss/libs/f3/base.php on line 1399
Status: 500
X-Powered-By: PHP/5.3.16
Content-type: text/html; charset=UTF-8

I activated DEBUG in config.ini, and I can see that it's updating about 15 feeds with a lot of XML errors like "Error error loading feed content: This XML document is invalid, likely due to invalid characters. XML error: SYSTEM or PUBLIC, the URI is missing at line 1, column 48" or "Undeclared entity error at line 70, column 111" or "EntityRef: expecting ';' at line 132, column 84" or "Not well-formed (invalid token) at line 1, column 1"... and after a while the log just stops.

And I have no updates at all showing.

Any help about how I could about debugging this would be very much appreciated !

thanks in advance.

uncaught exception on update

by zedug, Tuesday, April 23, 2013, 15:34 (3880 days ago) @ zedug

I decided to restart from scratch and remove all feeds and add only the last feed mentionned in the log and sure enough it craps out - still the same, log says it's working on it but the update hangs and nothing shows up in selfoss.

The problematic feed is http://krebsonsecurity.com/feed/

The log content (last lines) is

04-23-13 15:28:33 Debug ---
04-23-13 15:28:33 Debug start fetching source "Krebs On Security (id: 182)
04-23-13 15:28:33 Debug spout successfully loaded: spouts\rss\feed
04-23-13 15:28:33 Debug fetch content
04-23-13 15:28:34 Debug minimum date: 2013-03-24 15:28:34
04-23-13 15:28:34 Debug start item fetching
04-23-13 15:28:34 Debug start insertion of new item "Sources: Tea Leaves Say Breach at Teavana"
04-23-13 15:28:34 Debug item content sanitized

...so my question remains, how would I go about debugging that feed ? I tried using Readability but it made no difference.

RSS Feed of thread
powered by my little forum