Could not find driver

by Andtalath, Friday, March 15, 2013, 16:50 (4114 days ago)

I'm just getting a 500 error and:

Internal Server Error

could not find driver

This is with apache running on port 81.

Any ideas?

Current PHP installed:
ii libapache2-mod-php5 5.3.10-1ubuntu3.5 server-side, HTML-embedded scripting language (Apache 2 module)
ii php5 5.3.10-1ubuntu3.5 server-side, HTML-embedded scripting language (metapackage)
ii php5-cgi 5.3.10-1ubuntu3.5 server-side, HTML-embedded scripting language (CGI binary)
ii php5-cli 5.3.10-1ubuntu3.5 command-line interpreter for the php5 scripting language
ii php5-common 5.3.10-1ubuntu3.5 Common files for packages built from the php5 source
ii php5-mysql 5.3.10-1ubuntu3.5 MySQL module for php5
ii php5-xmlrpc 5.3.10-1ubuntu3.5 XML-RPC module for php5

Current apache installed:
ii apache2-mpm-prefork 2.2.22-1ubuntu1.2 Apache HTTP Server - traditional non-threaded model
ii apache2-utils 2.2.22-1ubuntu1.2 utility programs for webservers
ii apache2.2-bin 2.2.22-1ubuntu1.2 Apache HTTP Server common binary files
ii apache2.2-common 2.2.22-1ubuntu1.2 Apache HTTP Server common files
ii libapache2-mod-php5 5.3.10-1ubuntu3.5 server-side, HTML-embedded scripting language (Apache 2 module)
ii libapache2-mod-scgi 1.13-1ubuntu1 Apache module implementing the SCGI protocol

Could not find driver

by andersgd, Friday, March 15, 2013, 16:54 (4114 days ago) @ Andtalath

I guess it's a problem connecting to the database. Are you using sqlite, mysql or postgres?

Could not find driver

by Andtalath, Saturday, March 16, 2013, 09:26 (4113 days ago) @ andersgd

sqlite.

Eddys answer seemed to fix it.

Could not find driver

by Fred, Friday, March 15, 2013, 17:23 (4114 days ago) @ Andtalath

You will be missing the relevant database engine / libraries

Could not find driver

by Andtalath, Saturday, March 16, 2013, 09:26 (4113 days ago) @ Fred

Indeed, Eddy helped.

Could not find driver

by eddy, Friday, March 15, 2013, 18:27 (4114 days ago) @ Andtalath

I got this error when trying to use the default SQLite settings.

I tried a number of things to fix it, but I believe the thing that fixed it was when I installed the "php5-sqlite" package out of Ubuntu's repositories. I had to restart Apache a few times as well.

This won't help if you want to use MySQL though.

Could not find driver

by Andtalath, Saturday, March 16, 2013, 09:27 (4113 days ago) @ eddy

Ah, that seems to have done the trick.

Thansk!

RSS Feed of thread
powered by my little forum