items in the feed, but no items in selfoss

by winky, Friday, January 24, 2014, 11:25 (3833 days ago)

hey guys

could somebody explain why this is happen?

- using debian 7, apache 2.2.22, php 5.4.4
- added a valid rss-2.0-feed (w3c confirmed) in selfoss v2.8
- could find the source in sqlite:

sqlite> select * from sources where id is 52;
52|Dilbert - inofficial|FOO|spouts\rss\feed|{"url":"http:\/\/\/misc\/rss\/dilbert.xml"}||1390558203

- the update-process via cron is working very well, because all of my other feeds are up to date and the log seems to be without failure and the update-timestamp in sqlite is ok

bash# date -d @1390558203
Fri Jan 24 11:10:03 CET 2014
bash# tail -500 default.log | grep -A6 'id: 52'
01-24-14 11:10:02 Debug start fetching source "Dilbert - inofficial (id: 52)
01-24-14 11:10:02 Debug spout successfully loaded: spouts\rss\feed
01-24-14 11:10:02 Debug fetch content
01-24-14 11:10:02 Debug minimum date: 2013-10-26 11:10:02
01-24-14 11:10:02 Debug start item fetching
01-24-14 11:10:03 Debug destroy spout object
01-24-14 11:10:03 Debug ---

- but i couldn't find some items, whether in selfoss, nor in sqlite:

sqlite> select count(*) from items where source is 52;

i tried different feed-styles and different servers to host the rss but it's always the same behaviour. i cleared also the cache in selfoss, but this doesn't help.

any suggestions?

items in the feed, but no items in selfoss

by winky, Friday, January 24, 2014, 16:54 (3833 days ago) @ winky

i set up a new 2.9-instance, made an export of my 2.8-feeds, imported them into 2.9 and now it's working, but i don't know why.

anyway ... problem solved.

RSS Feed of thread
powered by my little forum