Access via HTTPS shows no stylesheet or images

by jcdus, Wednesday, March 20, 2013, 15:47 (4109 days ago) @ nLinked

Hi all,

I had the same issue, but the AllowOverride All wasn't enough to solve the problem: the web page produced by index.php was presented (which is ok), but with no images nor style.

The problem was an error 404 on:
https://server/selfoss/all.js
https://server/selfoss/all.css
and all the files in /var/www/selfoss/public

If this information can help someone, let me explain how I solved my issue:

1/ I made up a selfoss Directory for Selfoss in my Apache conf:

Alias /selfoss "/var/www/selfoss"
<Directory "/var/www/selfoss">
Options FollowSymLinks
Order Allow,Deny
Allow From All
AllowOverride All
</Directory>

2/ I copied the content of /var/www/selfoss/.htaccess in this Directory tag.

3/ I commented out the line:
RewriteBase /selfoss

4/ I deleted the /var/www/selfoss/.htaccess file

5/ Restart Apache, clean caches, access Selfoss and enjoy.

I guess that the "AllowOverride All" line is no more necessary, and maybe that a more obvious and cleaner solution exists, but that's my 2 cents for today.

Jean-Claude.


Complete thread:

 RSS Feed of thread

powered by my little forum